import re
regex = re.compile(r"(?<=\bREF)(?!:)", flags=re.MULTILINE)
test_str = ("DBZ:00000*{6000}/ONE/REFFERRARO REF:FINE DOGS*\n")
subst = ":"
result = regex.sub(subst, test_str)
if result:
print(result)