re = /(?<=\bREF)(?!:)/m
str = 'DBZ:00000*{6000}/ONE/REFFERRARO REF:FINE DOGS*
'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result