const regex = new RegExp('(?<=\\bREF)(?!:)', 'gm')
const str = `DBZ:00000*{6000}/ONE/REFFERRARO REF:FINE DOGS*
`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);