use strict;
my $str = 'DBZ:00000*{6000}/ONE/REFFERRARO REF:FINE DOGS*
';
my $regex = qr/(?<=\bREF)(?!:)/mp;
my $subst = ':';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";