using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[abc\].*)(kuku)(.*\[\/abc\])";
string substitution = @"\1\\\2\3";
string input = @"[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}