use strict;
my $str = '[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]';
my $regex = qr/(\[abc\].*)(kuku)(.*\[\/abc\])/mp;
my $subst = '\\1\\\\\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";