const regex = /(\[abc\].*)(kuku)(.*\[\/abc\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[abc\\].*)(kuku)(.*\\[\\\/abc\\])', 'gm')
const str = `[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]`;
const subst = `\1\\\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);