$re = '/(\[abc\].*)(kuku)(.*\[\/abc\])/m';
$str = '[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]';
$subst = "\1\\\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;