import re
regex = re.compile(r"(\[abc\].*)(kuku)(.*\[\/abc\])", flags=re.MULTILINE)
test_str = "[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]"
subst = "\\1\\\\\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)