import Foundation
let pattern = #"(\[abc\].*)(kuku)(.*\[\/abc\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\\\2\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)