#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)"
Local $sString = "<table class="grid grid-2">" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>" & @CRLF & _
"<p class="large-text">test</p>" & @CRLF & _
"</td>" & @CRLF & _
"<td>" & @CRLF & _
"<p class="large-text">test</p>" & @CRLF & _
"</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<table class="grid grid-3">" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>" & @CRLF & _
"<p style="text-align: center;">test</p>" & @CRLF & _
"</td>" & @CRLF & _
"<td>" & @CRLF & _
"<p style="text-align: center;">test</p>" & @CRLF & _
"</td>" & @CRLF & _
"<td>" & @CRLF & _
"<p style="text-align: center;">test</p>" & @CRLF & _
"</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<table class="grid grid-3">" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="large-text"> test</td>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")