re = /(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)/i
str = '<table class="grid grid-2">
<tbody>
<tr>
<td>
<p class="large-text">test</p>
</td>
<td>
<p class="large-text">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td class="large-text"> test</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end