import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<table.*?class=\"(.+?)\".*?>.+?<td>(.+?)<\\/td>.+?.+?<\\/table>)";
final String string = "<table class=\"grid grid-2\">\n"
+ "<tbody>\n"
+ "<tr>\n"
+ "<td>\n"
+ "<p class=\"large-text\">test</p>\n"
+ "</td>\n"
+ "<td>\n"
+ "<p class=\"large-text\">test</p>\n"
+ "</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>\n"
+ "<p> </p>\n"
+ "<table class=\"grid grid-3\">\n"
+ "<tbody>\n"
+ "<tr>\n"
+ "<td>\n"
+ "<p style=\"text-align: center;\">test</p>\n"
+ "</td>\n"
+ "<td>\n"
+ "<p style=\"text-align: center;\">test</p>\n"
+ "</td>\n"
+ "<td>\n"
+ "<p style=\"text-align: center;\">test</p>\n"
+ "</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>\n"
+ "<p> </p>\n"
+ "<table class=\"grid grid-3\">\n"
+ "<tbody>\n"
+ "<tr>\n"
+ "<td class=\"large-text\"> test</td>\n"
+ "<td></td>\n"
+ "<td></td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}