import Foundation
let pattern = #"(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<table class="grid grid-2">
<tbody>
<tr>
<td>
<p class="large-text">test</p>
</td>
<td>
<p class="large-text">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td class="large-text"> test</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)