using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<table.*?class=""(.+?)"".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)";
string input = @"<table class=""grid grid-2"">
<tbody>
<tr>
<td>
<p class=""large-text"">test</p>
</td>
<td>
<p class=""large-text"">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class=""grid grid-3"">
<tbody>
<tr>
<td>
<p style=""text-align: center;"">test</p>
</td>
<td>
<p style=""text-align: center;"">test</p>
</td>
<td>
<p style=""text-align: center;"">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class=""grid grid-3"">
<tbody>
<tr>
<td class=""large-text""> test</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}