use strict;
my $str = '<table class="grid grid-2">
<tbody>
<tr>
<td>
<p class="large-text">test</p>
</td>
<td>
<p class="large-text">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td class="large-text"> test</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>';
my $regex = qr/(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}