# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<table.*?class=\"(.+?)\".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)"
test_str = ("<table class=\"grid grid-2\">\n"
"<tbody>\n"
"<tr>\n"
"<td>\n"
"<p class=\"large-text\">test</p>\n"
"</td>\n"
"<td>\n"
"<p class=\"large-text\">test</p>\n"
"</td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"<p> </p>\n"
"<table class=\"grid grid-3\">\n"
"<tbody>\n"
"<tr>\n"
"<td>\n"
"<p style=\"text-align: center;\">test</p>\n"
"</td>\n"
"<td>\n"
"<p style=\"text-align: center;\">test</p>\n"
"</td>\n"
"<td>\n"
"<p style=\"text-align: center;\">test</p>\n"
"</td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"<p> </p>\n"
"<table class=\"grid grid-3\">\n"
"<tbody>\n"
"<tr>\n"
"<td class=\"large-text\"> test</td>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"</tbody>\n"
"</table>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.