// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)"#).unwrap();
let string = "<table class=\"grid grid-2\">
<tbody>
<tr>
<td>
<p class=\"large-text\">test</p>
</td>
<td>
<p class=\"large-text\">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class=\"grid grid-3\">
<tbody>
<tr>
<td>
<p style=\"text-align: center;\">test</p>
</td>
<td>
<p style=\"text-align: center;\">test</p>
</td>
<td>
<p style=\"text-align: center;\">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class=\"grid grid-3\">
<tbody>
<tr>
<td class=\"large-text\"> test</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}