const regex = /(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\/td>.+?.+?<\/table>)/isg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<table.*?class="(.+?)".*?>.+?<td>(.+?)<\\\/td>.+?.+?<\\\/table>)', 'isg')
const str = `<table class="grid grid-2">
<tbody>
<tr>
<td>
<p class="large-text">test</p>
</td>
<td>
<p class="large-text">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
<td>
<p style="text-align: center;">test</p>
</td>
</tr>
</tbody>
</table>
<p> </p>
<table class="grid grid-3">
<tbody>
<tr>
<td class="large-text"> test</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}