using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))";
string substitution = @" = NULL";
string input = @"$a, $a, $a
$a, $a = '', $a
$a
$a,
$a = '', $a";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}