const regex = /(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\$[A-Za-z0-9\\-\\_ ]+)(?=(?:,|$))', 'igm')
const str = `\$a, \$a, \$a
\$a, \$a = '', \$a
\$a
\$a,
\$a = '', \$a`;
const subst = ` = NULL`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);