import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\$[A-Za-z0-9\\-\\_ ]+)(?=(?:,|$))";
final String string = "$a, $a, $a\n"
+ "$a, $a = '', $a\n"
+ "$a\n"
+ "$a,\n"
+ "$a = '', $a";
final String subst = " = NULL";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}