use strict;
my $str = '$a, $a, $a
$a, $a = \'\', $a
$a
$a,
$a = \'\', $a';
my $regex = qr/(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/imp;
my $subst = ' = NULL';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";