import re
regex = re.compile(r"(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("$a, $a, $a\n"
"$a, $a = '', $a\n"
"$a\n"
"$a,\n"
"$a = '', $a")
subst = " = NULL"
result = regex.sub(subst, test_str)
if result:
print(result)