using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{link}{(.*?)}{(.*?)}{link}";
string substitution = @"<a href=\1>\2</a>";
string input = @"""Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}