const regex = /{link}{(.*?)}{(.*?)}{link}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{link}{(.*?)}{(.*?)}{link}', 'g')
const str = `"Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}"`;
const subst = `<a href=\1>\2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);