use strict;
my $str = '"Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}"';
my $regex = qr/{link}{(.*?)}{(.*?)}{link}/p;
my $subst = '<a href=\\1>\\2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";