$re = '/{link}{(.*?)}{(.*?)}{link}/';
$str = '"Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}"';
$subst = "<a href=\1>\2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;