package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{link}{(.*?)}{(.*?)}{link}`)
var str = `"Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}"`
var substitution = "<a href=\1>\2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}