import Foundation
let pattern = #"{link}{(.*?)}{(.*?)}{link}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href=\1>\2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)