import re
regex = re.compile(r"{link}{(.*?)}{(.*?)}{link}")
test_str = "\"Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}\""
subst = "<a href=\\1>\\2</a>"
result = regex.sub(subst, test_str)
if result:
print(result)