#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$"
Local $sString = "AXISBANK26May2022 CE 660" & @CRLF & _
"AXISBANK26May2022 CE 690" & @CRLF & _
"AXISBANK26May2022 PE 670" & @CRLF & _
"BANKNIFTY19May2022 PE 30200" & @CRLF & _
"BANKNIFTY19May2022 PE 31200" & @CRLF & _
"BANKNIFTY26May2022 PE 34300" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")