# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$"
test_str = ("AXISBANK26May2022 CE 660\n"
"AXISBANK26May2022 CE 690\n"
"AXISBANK26May2022 PE 670\n"
"BANKNIFTY19May2022 PE 30200\n"
"BANKNIFTY19May2022 PE 31200\n"
"BANKNIFTY26May2022 PE 34300\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.