using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$";
string input = @"AXISBANK26May2022 CE 660
AXISBANK26May2022 CE 690
AXISBANK26May2022 PE 670
BANKNIFTY19May2022 PE 30200
BANKNIFTY19May2022 PE 31200
BANKNIFTY26May2022 PE 34300
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}