import Foundation
let pattern = #"(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AXISBANK26May2022 CE 660
AXISBANK26May2022 CE 690
AXISBANK26May2022 PE 670
BANKNIFTY19May2022 PE 30200
BANKNIFTY19May2022 PE 31200
BANKNIFTY26May2022 PE 34300
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)