use strict;
my $str = 'AXISBANK26May2022 CE 660
AXISBANK26May2022 CE 690
AXISBANK26May2022 PE 670
BANKNIFTY19May2022 PE 30200
BANKNIFTY19May2022 PE 31200
BANKNIFTY26May2022 PE 34300
';
my $regex = qr/(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}