const regex = new RegExp('(\\d{2}[^\\W\\d]{3}\\d{4})\\s+([A-Z]+)\\s+(\\d+)$', 'gm')
const str = `AXISBANK26May2022 CE 660
AXISBANK26May2022 CE 690
AXISBANK26May2022 PE 670
BANKNIFTY19May2022 PE 30200
BANKNIFTY19May2022 PE 31200
BANKNIFTY26May2022 PE 34300
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}