$re = '/(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$/m';
$str = 'AXISBANK26May2022 CE 660
AXISBANK26May2022 CE 690
AXISBANK26May2022 PE 670
BANKNIFTY19May2022 PE 30200
BANKNIFTY19May2022 PE 31200
BANKNIFTY26May2022 PE 34300
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);