import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}[^\\W\\d]{3}\\d{4})\\s+([A-Z]+)\\s+(\\d+)$";
final String string = "AXISBANK26May2022 CE 660\n"
+ "AXISBANK26May2022 CE 690\n"
+ "AXISBANK26May2022 PE 670\n"
+ "BANKNIFTY19May2022 PE 30200\n"
+ "BANKNIFTY19May2022 PE 31200\n"
+ "BANKNIFTY26May2022 PE 34300\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}