package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2}[^\W\d]{3}\d{4})\s+([A-Z]+)\s+(\d+)$`)
var str = `AXISBANK26May2022 CE 660
AXISBANK26May2022 CE 690
AXISBANK26May2022 PE 670
BANKNIFTY19May2022 PE 30200
BANKNIFTY19May2022 PE 31200
BANKNIFTY26May2022 PE 34300
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}