# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\w\ ]+)(?:\/([\w\ ]+))?(?:\/([\w\ ]+))?(?:\/([\w\ ]+))?(?:\/([\w\ ]+))?(?:\/([\w\ ]+))?\/?$/route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6/g;t' <<< "hey/dude/yo%20man%2C%20what%27s%20up%3F/"