const regex = new RegExp('^([\\w\\ ]+)(?:/([\\w\\ ]+))?(?:/([\\w\\ ]+))?(?:/([\\w\\ ]+))?(?:/([\\w\\ ]+))?(?:/([\\w\\ ]+))?/?$', 'g')
const str = `hey/dude/yo%20man%2C%20what%27s%20up%3F/`;
const subst = `route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);