$re = '/^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$/';
$str = 'hey/dude/yo%20man%2C%20what%27s%20up%3F/';
$subst = "route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;