import re
regex = re.compile(r"^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$")
test_str = "hey/dude/yo%20man%2C%20what%27s%20up%3F/"
subst = "route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6"
result = regex.sub(subst, test_str)
if result:
print(result)