use strict;
my $str = 'hey/dude/yo%20man%2C%20what%27s%20up%3F/';
my $regex = qr/^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$/p;
my $subst = 'route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";