using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$";
string substitution = @"route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6";
string input = @"hey/dude/yo%20man%2C%20what%27s%20up%3F/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}