#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?xm)^" & @CRLF & _
"(?:|" & @CRLF & _
" [^;"'\r\n]*" & @CRLF & _
" (?:" & @CRLF & _
" (?:'[^'\r\n]*')|" & @CRLF & _
" (?:"[^"\r\n]*")" & @CRLF & _
" )*" & @CRLF & _
")" & @CRLF & _
"\h*" & @CRLF & _
";\h*([^\r\n]*)"
Local $sString = "; test" & @CRLF & _
"; "test"" & @CRLF & _
"; "test'" & @CRLF & _
"; 'test'" & @CRLF & _
"; 'test"" & @CRLF & _
"$x='' ; chaîne "vide"" & @CRLF & _
"$x="" ; chaîne "vide"" & @CRLF & _
"$x="" ; chaîne 'vide'" & @CRLF & _
"$x = "aa;aa" ; Comment-line" & @CRLF & _
"$x = "a" ;$x='b'" & @CRLF & _
"$;x = "aa;aa" ; Comment-line" & @CRLF & _
"$x=' '' '';'' ";" "'' ''" "''"' ; chaîne "vide"" & @CRLF & _
"$x=' '' '';'' ";" "'' ''" "''"' ; chaîne 'vide'" & @CRLF & _
"$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne "vide"" & @CRLF & _
"$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne 'vide'" & @CRLF & _
"" & @CRLF & _
""" ; commentaire" & @CRLF & _
"" & @CRLF & _
"$x = 'bb;b'" & @CRLF & _
"$x = "bb;b"" & @CRLF & _
"$x = " " & "bb"" & @CRLF & _
"" & @CRLF & _
";;;;" & @CRLF & _
"; ; ;";'" & @CRLF & _
"";iii" & @CRLF & _
"';uuu;uuu";uuu';aa" & @CRLF & _
" ; test" & @CRLF & _
"" i " ; a ; a" & @CRLF & _
"" i " ; ; a ; a" & @CRLF & _
"" i " ; a ; a ; a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")