const regex = /(?xm)^
(?:|
[^;"'\r\n]*
(?:
(?:'[^'\r\n]*')|
(?:"[^"\r\n]*")
)*
)
\h*
;\h*([^\r\n]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?xm)^
(?:|
[^;"\'\\r\\n]*
(?:
(?:\'[^\'\\r\\n]*\')|
(?:"[^"\\r\\n]*")
)*
)
\\h*
;\\h*([^\\r\\n]*)', 'gm')
const str = `; test
; "test"
; "test'
; 'test'
; 'test"
\$x='' ; chaîne "vide"
\$x="" ; chaîne "vide"
\$x="" ; chaîne 'vide'
\$x = "aa;aa" ; Comment-line
\$x = "a" ;\$x='b'
\$;x = "aa;aa" ; Comment-line
\$x=' '' '';'' ";" "'' ''" "''"' ; chaîne "vide"
\$x=' '' '';'' ";" "'' ''" "''"' ; chaîne 'vide'
\$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne "vide"
\$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne 'vide'
"" ; commentaire
\$x = 'bb;b'
\$x = "bb;b"
\$x = " " & "bb"
;;;;
; ; ;";'
";iii
';uuu;uuu";uuu';aa
; test
" i " ; a ; a
" i " ; ; a ; a
" i " ; a ; a ; a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}