re = /(?xm)^
(?:|
[^;"'\r\n]*
(?:
(?:'[^'\r\n]*')|
(?:"[^"\r\n]*")
)*
)
\h*
;\h*([^\r\n]*)/xm
str = '; test
; "test"
; "test\'
; \'test\'
; \'test"
$x=\'\' ; chaîne "vide"
$x="" ; chaîne "vide"
$x="" ; chaîne \'vide\'
$x = "aa;aa" ; Comment-line
$x = "a" ;$x=\'b\'
$;x = "aa;aa" ; Comment-line
$x=\' \'\' \'\';\'\' ";" "\'\' \'\'" "\'\'"\' ; chaîne "vide"
$x=\' \'\' \'\';\'\' ";" "\'\' \'\'" "\'\'"\' ; chaîne \'vide\'
$x=" \' \';\' "";"" ""\' \'"" ""\'""" ; chaîne "vide"
$x=" \' \';\' "";"" ""\' \'"" ""\'""" ; chaîne \'vide\'
"" ; commentaire
$x = \'bb;b\'
$x = "bb;b"
$x = " " & "bb"
;;;;
; ; ;";\'
";iii
\';uuu;uuu";uuu\';aa
; test
" i " ; a ; a
" i " ; ; a ; a
" i " ; a ; a ; a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end