import Foundation
let pattern = #"""
(?xm)^
(?:|
[^;"'\r\n]*
(?:
(?:'[^'\r\n]*')|
(?:"[^"\r\n]*")
)*
)
\h*
;\h*([^\r\n]*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
; test
; "test"
; "test'
; 'test'
; 'test"
$x='' ; chaîne "vide"
$x="" ; chaîne "vide"
$x="" ; chaîne 'vide'
$x = "aa;aa" ; Comment-line
$x = "a" ;$x='b'
$;x = "aa;aa" ; Comment-line
$x=' '' '';'' ";" "'' ''" "''"' ; chaîne "vide"
$x=' '' '';'' ";" "'' ''" "''"' ; chaîne 'vide'
$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne "vide"
$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne 'vide'
"" ; commentaire
$x = 'bb;b'
$x = "bb;b"
$x = " " & "bb"
;;;;
; ; ;";'
";iii
';uuu;uuu";uuu';aa
; test
" i " ; a ; a
" i " ; ; a ; a
" i " ; a ; a ; a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)